Updating Drupal from 5.1 to 5.3

I just had a heck of a time attempting to upgrade this site from Drupal 5.1 to 5.3.

The short version:

I used Fantastico on my cPanel to start the upgrade. Got an unrecoverable error. Restored files and database manually. Attempted manual upgrade. Got same error. Discovered that error was unique to Firefox/Mozilla. Updated manually with IE.

All is now OK.

The end.